Using Quality Center 9.2

Course Setup Instructions

This document contains system and software requirements required for this training and setup instructions. Please
return the completed and signed checklist to HP. See last page for full return instructions.

Important Note:

This training runs under the following operating systems:

e Windows Server 2003 with Service Pack 1 Standard/Enterprise Edition
e Windows 2000 Server with Service Pack 4

Courses This Document Supports:
1. Using Quality Center 9.2 (Book Version: QC92U-S-01B)

Minimum system requirements for each machine:
CPU: Pentium® 4
Memory: 1 GB minimum
Disk Space: 3 GB
J2EE App Server — One of the following
e JBoss 4.0 (included with Quality Center)
e Weblogic 8.1.5
Web Server — One of the following

e [IS5.0/6.0
e Apache 2.0.54
e JBoss 4.0

e Weblogic 8.1.5
Database — One of the following
e Oracle 9.2.0.5 Enterprise Edition
e Oracle 10.0 g Release 1 or 2 Standard/Enterprise Edition
e MS/SQL Server 2000 Standard/Enterprise Edition
Quality Center 9.2 (with license)
Browser — One of the following
e Microsoft Internet Explorer 6.0 with Service Pack 1
e Quality Center Explorer
QuickTest Professional 9.2 (with license)
LoadRunner 8.1 with Service Pack 4 (with license)
Microsoft® Word 97 or higher
Microsoft® Excel 97 or higher
Microsoft Word Add-in for Quality Center
Microsoft Excel Add-in for Quality Center
Microsoft ® PowerPoint ® 97 or higher
HP fonts (for slides)
QC92Using-SetupFiles-01A.zip (contains the LoadRunner and QuickTest Professional test scripts)*
QC92Using-Training-01A.zip (contains the exercise files)*



* The QC92Using-SetupFiles-01A.zip and QC92Using-Training-01A.zip files should be downloaded from the
Education Services web site at http://www.merc-training.com. Select “Current Courses” to find the download
link. No password is necessary.

CHECK LIST

Please check each item that you have available for this training:
[J Received Quality Center 9.2 for installation on CD
[ Downloaded QC92Using-Training-01A.zip (contains exercise files)

[ Downloaded QC92Using-SetupFiles-01A.zip (contains the QuickTest Professional and LoadRunner test scripts)
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NOTE:
Microsoft Debugger files can be downloaded from this link:
http://www.microsoft.com/downloads/results.aspx?productl D=&freetext=script+debugger&Displaylang=en

Files to be downloaded may be obtained from the Education Services Web site at: http://www.merc-training.com.
Select “Current Courses” to find the download link. No password is necessary.

Other Software Required:
LI Zip utility software like WinZip or PKZip (required to unzip training files.)

Operating System:
Which Windows platform do you intend to use in this training?
Windows

Version of Quality Center used:
Please confirm which version of Quality Center you installed: Quality Center

NOTE: Files to be downloaded may be obtained from the Education Services web site at http://www.merc-
training.com. Select “Current Courses” to find the download link. No password is necessary.
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Checklist and Training Setup Instructions

For this class, the instructor and each student has an individual copy of Quality Center. The instructions below
should be followed for each machine that will be used in the class.

All installations require Administrative privileges.

Please check each item below when complete:

A. QUALITY CENTER INSTALL

O 1. Install Quality Center. This course requires that Quality Center must be installed.

e A basic installation of Quality Center should be performed per the
product installation guide. This installation must be done with
Administrative Privileges.

e Download and install the QuickTest Professional Add-in for Quality
Center from the Quality Center Add-Ins page.
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B. PROJECT SETUP

O

O

O

1. Create the training user account. 1.

All lab exercises in this course will
have students log in using the training 2.
user account and welcome password.

10.

11.

2. Create the TRAINING domain

3. Create the FlightApplication project.

Launch Quality Center (standard URL format is http://<Quality
Center server name>:<port>/qcbin).

From the Quality Center login page, click Site Administration. This
opens the Site Administration login page.

Enter the User name and Password.

Click the Login button.

On the Site Administration page, click the Site Users tab.

Click the New User button. This opens the New User dialog box.
Enter User Name as training and click OK.

Under the Site Users tab, all the users are listed. Select training.
Click the Password button that appears on the right side of the
screen, below the DB Servers tab. The Set User Password dialog
box appears.

Enter welcome in the New Password and Retype Password fields.

Click OK.

On the Site Administration page, click the Site Projects tab.
On the Site Projects tab, click Create Domain.

In the Domain Name field, type TRAINING and click OK.

From the Site Project list, select the TRAINING domain.

Click Create Project.

Select the Create an empty project option and click Next.
In the Project Name field, type FlightApplication.

Verity the database server log on credentials and click Next.

Add the training user to the Project Administrators list and click
Next.

Ensure that the Activate Project check box is checked and click
Create.

Log off from Site Administration.
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O

4. Add automated tests to the test plan 1.
tree.

Log on to the FlightApplication project in the TRAINING domain by
using the training username and the welcome password.

2. Navigate to the Test Plan module.

3. In the test plan tree, create a folder with the name — Automated Tests.

4. Unzip the QC92Using-SetupFiles-01A.zip file. The file contains the
Book_Flight_QTP.zip (QuickTest Professional test script),
Book_Flight_Scenario.zip (LoadRunner Scenario script), and
Book_Flight.zip (LoadRunner Test Script).

5. To copy the Book_Flight_QTP test script fo the Book Flight test in the
Test Plan module:

Launch QuickTest Professional.

Unzip the Book_Flight_QTP.zip folder and open the test in
QuickTest Professional.

From the QuickTest Professional menu bar, select File >
Quality Center Connection to open the Quality Center
Connection dialog box

Connect to the Quality Center server by using the training
username and welecome password to connect to the
FlightApplication Quality Center project in the TRAINING
domain.

After the connection is established, close the Quality Center
Connection dialog box.

From the menu bar, select File > Save As to save the test
in the Automated Tests folder in the Test Plan module with

the name Book Flight.

Close QuickTest Professional.
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6. To copy the Book_Flight LoadRunner test script to the Book Flight
Scenario test in the Test Plan module:

Launch LoadRunner Virtual User Generator.

Unzip the Book_Flight.zip folder and open the test in Virtual
User Generator.

From the menu bar, select Tools > Quality Center
Connection. The Quality Center Connection dialog box
appears.

Connect to the FlightApplication Quality Center project in
the TRAINING domain by using the training username
and welcome password.

Atter the connection is established, close the Quality Center
Connection dialog box.

From the menu bar, select File > Save As to save the test
in the Automated Tests folder with the name Book Flight
Script.

7. To copy the Book_Flight_Scenario test script to the Book Flight
Scenario in the Test Plan module:

Launch LoadRunner Controller.

a.

b. Unzip Book_Flight_Scenario.zip and open the scenario in
LoadRunner Controller.

c. From the menu bar, select Tools > Quality Center
Connection. The Quality Center Connection dialog box
appears.

d. Connect to the FlightApplication Quality Center project in
the TRAINING domain by using the training username
and welcome password.

e. After the connection is established, close the Quality Center
Connection dialog box.

f.  From the menu bar, select File > Save As to save the test
in the Automated Tests folder with the name Book Flight
Scenario.

g. Close the LoadRunner Controller.
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O 5. Add requirements to the requirements 1. Navigate to the Requirements module.

free. 2. Select the Requirements folder and on the toolbar, click the New

Folder button. The Create New Requirement Folder dialog box
appears.

3. In the Create New Requirement Folder dialog box, in the Folder
Name field, type Functional.

4. Click OK to close the Create New Requirement Folder dialog box.

On the toolbar, click the New Requirement button. The Create
New Requirement dialog box appears.

6. In the Create New Requirement dialog box, from the Requirement
Type list, select Business.

7. In the Requirement Type field, type Orders.
Click OK. The New Requirement dialog box appears.

9. From the Priority list, select 4-Very High.
10. Click Submit.
11. Click Close to close the New Requirement dialog box.

12. On the toolbar, click the New Requirement bution. The Create
New Requirement dialog box appears.

13. In the Create New Requirement dialog box, from the Requirement
Type list, select Functional.

14. In the Requirement Name field, type Create New Order.
15. Click OK. The New Requirement dialog box appears.

16. In the New Requirement dialog box, from the Direct Cover Status
and Priority lists, select No Run and 4-Very High, respectively.

17. Click Submit.
18. Click Close.
19. From the requirements tree, select Orders.

20. On the toolbar, click the New Requirement bution. The Create
New Requirement dialog box appears.

21. In the Requirement Type list, ensure that Functional is selected.

22. In the New Requirement dialog box, in the Name field, type
Update Order.

23. Click OK. The New Requirement dialog box appears.

24. From the Direct Cover Status and Priority lists, select No Run and
3-High, respectively.

25. Click Submit.

26. In the New Requirement dialog box, in the Name field, type Delete
Order.

27. In the Requirement Type list, ensure that Functional is selected.

28. From the Direct Cover Status and Priority lists, select No Run and
3-High, respectively.

29. Click Submit and click Close.
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On All Student Machines:

C. INSTALL QUICKTEST PROFESSIONAL

O 1. Install QuickTest Professional.

2. Install the QuickTest Professional Add-in
O for Quality Center.

D. INSTALL LOADRUNNER

This course requires that QuickTest Professional be installed.

A basic installation of QuickTest Professional should be performed according
to the product installation guide. This installation must be done with
Administrative Privileges.

Install the QuickTest Professional Add-in for Quality Center from the Quality
Center Add-Ins page.
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O

O

1. Install LoadRunner.

2. Configure Xitami Web Server

3. Verify that you are able to invoke the
QuickTest and LoadRunner test scripts
from the all the student machines.

This course requires that LoadRunner be installed.

A basic installation of LoadRunner should be performed according to the
product installation guide. This installation must be done with Administrative
Privileges.

Start the Xitami Web Server: Start > Programs > Mercury
LoadRunner > Samples > Web > Start Web Server

Right click the Xitami Web Server Icon in the Task Tray 4 and select
Properties.

In the Properties dialog, check the box next to “Autorun on Login”

Click Close.

Log on to the FlightApplication project in the TRAINING domain by
using the training user name and the welcome password on a
student machine.

Navigate to the Test Plan module.
Verify that you are able to use the test scripts for the Book Flight

(QUICKTEST_TEST) and Book Flight Performance (LR-SCENARIO) tests

from two or more student machines.
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O 1. Download and unzip the training files. The QC92Using-Training-01A.zip file contains the following files:

FlightSearch_Req.xls

PaymentMethods_Req.xls

FlightTrip_Req.doc
e PaymentMethods_Req.doc

Save these files in the C:\Training\Quality Center 9.2\Using directory.

Setup Verification:

After you have verified the setup of all machines to be used in the training, please fax the completed
checklist to your PSO logistic coordinator. In order for HP to have time to review the information, please fax
the completed checklist at least two working days before the start of the training event. Thank you for your
cooperation.

Signature

Print Name and Title

Company/Organization Name

Date
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